CyberSecBulletin

Nlnetlabs vulnerabilities

We track 4 vulnerabilities in Nlnetlabs products across 2 products. 4 are rated high or critical, and none are known to be exploited. The most recent was published on July 20, 2026.

4vulnerabilities
1critical
3high
0exploited
8.1average CVSS score

Latest Nlnetlabs vulnerabilities

  • 7.5 High severity

    Net::DNS: Uncontrolled Recursion

    CVE-2026-64194Nlnetlabs

    Net::DNS versions through 1.55 for Perl allow Denial of Service via deep DNS compression pointer chains. Net::DNS::DomainName::decode follows RFC 1035 compression pointers by recursing into itself with no depth limit. It is possible to construct a name which s

  • 9.8 Critical severity

    Net::DNS: Improper Neutralization of Directives in Dynamically Evaluated Code

    CVE-2026-64193NlnetlabsEPSS 1.44%

    Net::DNS versions through 1.55 for Perl allow remote execution injection via EDNS EXTENDED ERROR. Net::DNS::RR::OPT::EXTENDED_ERROR::_decompose parses the EXTRA-TEXT field of an EDNS EXTENDED-ERROR option (RFC 8914) by tokenising the raw bytes and passing the

  • 7.5 High severity

    Unbound: Loop with Unreachable Exit Condition

    CVE-2024-1931NLnet LabsEPSS 2.52%

    NLnet Labs Unbound version 1.18.0 up to and including version 1.19.1 contain a vulnerability that can cause denial of service by a certain code path that can lead to an infinite loop. Unbound 1.18.0 introduced a feature that removes EDE records from responses

  • 7.5 High severity

    Enterprise Linux: Allocation of Resources Without Limits or Throttling

    CVE-2023-50387Red HatEPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when ther