CyberSecBulletin

ISC vulnerabilities

We track 62 vulnerabilities in ISC products across 5 products. 62 are rated high or critical, and 1 has been exploited in real attacks. The most recent was published on October 21, 2026.

62vulnerabilities
1critical
61high
1exploited
7.6average CVSS score

Latest ISC vulnerabilities

  • 7.5 High severity

    BIND 9: Allocation of Resources Without Limits or Throttling

    CVE-2024-0760ISCEPSS 4.68%

    A malicious client can send many DNS messages over TCP, potentially causing the server to become unstable while the attack is in progress. The server may recover after the attack ceases. Use of ACLs will not mitigate the attack. This issue affects BIND 9 versi

  • 8.1 High severity

    Stork: Improper Certificate Validation

    CVE-2024-28872ISC

    The TLS certificate validation code is flawed. An attacker can obtain a TLS certificate from the Stork server and use it to connect to the Stork agent. Once this connection is established with the valid certificate, the attacker can send malicious commands to

  • 7.5 High severity

    Hci Baseboard Management Controller: Uncontrolled Resource Consumption

    CVE-2023-50868NetAppEPSS 74.3%

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC

  • 7.5 High severity

    Enterprise Linux: Allocation of Resources Without Limits or Throttling

    CVE-2023-50387Red HatEPSS 100%

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when ther

  • 7.5 High severity

    BIND 9: Allocation of Resources Without Limits or Throttling

    CVE-2023-6516ISCEPSS 1.1%

    To keep its cache database efficient, `named` running as a recursive resolver occasionally attempts to clean up the database. It uses several methods, including some that are asynchronous: a small chunk of memory pointing to the cache element that can be clean

  • 7.5 High severity

    BIND 9: Reachable Assertion

    CVE-2023-5679ISCEPSS 1.28%

    A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.

  • 7.5 High severity

    BIND 9: Reachable Assertion

    CVE-2023-5517ISCEPSS 1.28%

    A flaw in query-handling code can cause `named` to exit prematurely with an assertion failure when: - `nxdomain-redirect <domain>;` is configured, and - the resolver receives a PTR query for an RFC 1918 address that would normally result in an authoritative NX

  • 7.5 High severity

    BIND 9: Inefficient Algorithmic Complexity

    CVE-2023-4408ISCEPSS 1.39%

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by exp

  • 7.5 High severity

    BIND 9: Reachable Assertion

    CVE-2023-4236ISCEPSS 2.19%

    A flaw in the networking code handling DNS-over-TLS queries may cause `named` to terminate unexpectedly due to an assertion failure. This happens when internal data structures are incorrectly reused under significant DNS-over-TLS query load. This issue affects

  • 7.5 High severity

    BIND 9: Out-of-bounds Write

    CVE-2023-3341ISCEPSS 2.93%

    The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing. Recursion depth is only limited by the maximum accepted packet size; depending on the environment, this may cause the packet-parsing cod

  • 7.5 High severity

    BIND 9: Out-of-bounds Write

    CVE-2023-2911ISCEPSS 2.43%

    If the `recursive-clients` quota is reached on a BIND 9 resolver configured with both `stale-answer-enable yes;` and `stale-answer-client-timeout 0;`, a sequence of serve-stale-related lookups could cause `named` to loop and terminate unexpectedly due to a sta

  • 7.5 High severity

    BIND 9: Allocation of Resources Without Limits or Throttling

    CVE-2023-2828ISCEPSS 3.7%

    Every `named` instance configured to run as a recursive resolver maintains a cache database holding the responses to the queries it has recently sent to authoritative servers. The size limit for that cache database can be configured using the `max-cache-size`

  • 7.5 High severity

    BIND 9: Reachable Assertion

    CVE-2022-3924ISCEPSS 16%

    This issue can affect BIND 9 resolvers with `stale-answer-enable yes;` that also make use of the option `stale-answer-client-timeout`, configured with a value greater than zero. If the resolver receives many queries that require recursion, there will be a corr

  • 7.5 High severity

    BIND 9 resolver can crash when stale cache and stale answers are enabled, option…

    CVE-2022-3736ISCEPSS 48.4%

    BIND 9 resolver can crash when stale cache and stale answers are enabled, option `stale-answer-client-timeout` is set to a positive integer, and the resolver receives an RRSIG query. This issue affects BIND 9 versions 9.16.12 through 9.16.36, 9.18.0 through 9.

  • 7.5 High severity

    BIND 9: Reachable Assertion

    CVE-2022-3488ISCEPSS 19%

    Processing of repeated responses to the same query, where both responses contain ECS pseudo-options, but where the first is broken in some way, can cause BIND to exit with an assertion failure. 'Broken' in this context is anything that would cause the resolver

  • 7.5 High severity

    BIND 9: Use After Free

    CVE-2022-3094ISCEPSS 13.2%

    Sending a flood of dynamic DNS updates may cause `named` to allocate large amounts of memory. This, in turn, may cause `named` to exit due to a lack of free memory. We are not aware of any cases where this has been exploited. Memory is allocated prior to the c

  • 7.5 High severity

    BIND9: Missing Release of Memory after Effective Lifetime

    CVE-2022-38178ISCEPSS 3.11%

    By spoofing the target resolver with responses that have a malformed EdDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources.

  • 7.5 High severity

    BIND9: Missing Release of Memory after Effective Lifetime

    CVE-2022-38177ISCEPSS 3.29%

    By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources.

  • 7.5 High severity

    BIND9: Missing Release of Memory after Effective Lifetime

    CVE-2022-2906ISCEPSS 2.05%

    An attacker can leverage this flaw to gradually erode available memory to the point where named crashes for lack of resources. Upon restart the attacker would have to begin again, but nevertheless there is the potential to deny service.

  • 7.5 High severity

    BIND9: Reachable Assertion

    CVE-2022-1183ISCEPSS 6.24%

    On vulnerable configurations, the named daemon may, in some circumstances, terminate with an assertion failure. Vulnerable configurations are those that include a reference to http within the listen-on statements in their named.conf. TLS is used by both DNS ov

  • 7.5 High severity

    BIND: Reachable Assertion

    CVE-2022-0635ISCEPSS 1.37%

    Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the named process will eventually terminate due to a failed assertion check.

  • 7.8 High severity

    ISC BIND Data Processing Errors Exploited

    CVE-2015-5477Juniper NetworksEPSS 99.6%

    named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via TKEY queries.